NAV TechDays 2015 wrap up

Another NAV TechDays is over, and this one was the best so far. 950 people from all over the world all passionate about NAV and technology and eager to learn and share and discuss the latest in NAV. It was amazing, Luc did a great job again, and I am looking forward to the next year, hoping this conference makes it beyond 1000 attendees.

This year I have delivered a yet another “Black Belt” session named “Client Add-ins Black Belt: bringing .NET and JavaScript together” and as promised, I deliver the session material here on my blog.

So let’s start:

As always with these materials – I provide all of this as-is, make no guarantees, claims, or whatever. Use it, or abuse it, and see if it works for you. If it does, please let me know by making a comment here.

This time I honestly hope I will find enough time to take the concepts I presented out of the pile you find here in the materials I posted. I’ve got quite a lot of great and encouraging feedback, and I know a lot of you want to know more about the mechanics behind the concepts I demonstrated. But time is relative, I heard, and it’s never been my best friend. Let’s see. But rest assured that I want to blog about it as much as you want me to.

Once again, thanks for great feedback – it’s you folks that keep me doing this. Thanks for supporting me for a long time, and I hope to see you again in Antwerp, Prague, Chandler, or at one of many Cloud SureStep for NAV Architects trainings that are planned for next year.

6 thoughts on “NAV TechDays 2015 wrap up”

  1. Been trying to implement the .net assembly resolver part of the presentation (part 4) but i have kinda run into a chicken/egg problem. The code in codeunit 76101 fails on line 5 and returns a uninitiated object! (Guess it cant find the typename) But I can’t edit the codeunit since I do not have the dll file it tries to build! After some investigation I am kinda stuck! Any suggestions?

  2. I have watch the video several times, but can’t seem to get the call made in Codeunit 1 to work.

    When I manually run codeunit 76101 I get an error:

    “A DotNet variable has not been instantiated. Attempting to call System.Object.GetType in CodeUnit Assembly Resolver: ResolveAssembly

    Any ideas?
    Thanks

Leave a Reply